User Help Guides

 
A message from Sharp School

As SharpSchool looks to improve your product experience, we are moving past the support of older browsers. As of July 1st, 2014, SharpSchool will no longer support internet browsers that are older than Internet Explorer 8, Firefox 16, Chrome 26, Opera 12.1 or Safari 5.1

This is the way the internet is evolving. Many cool new features are not supported in older browsers and they're often faced with usability limitations. They're also prone to viruses. In fact, many leading firms like Google, Facebook and even Microsoft have stopped supporting older versions of browsers for these very reasons.

To get the most out of your SharpSchool website, please update your internet browser to its most recent version. 

To make things easier, you can update your browser by following the links below:
  We apologize for any inconveniences this may cause but this is something we need to do in order to give you the best possible website experience!

If you have any questions, our support team is always ready to help.